Broadband-Hamnet™ Forum :: Problems & Answers
Welcome Guest   [Register]  [Login]
 Subject :Reflash wrt54gl with linksys firmware... 2016-10-31- 21:11:27 
Joined: 2016-09-10- 03:35:04
Posts: 1

Hi All,

I have a wrt54gl that i would like to change back to factory or dd-wrt firmware.

I have tried various ways after trolling all the internet etc.

Any one on here have a sure fire way to do it.

Many thaanks,


IP Logged
 Subject :Re:Reflash wrt54gl with linksys firmware... 2017-04-30- 00:04:11 
Joined: 2014-09-24- 10:52:45
Posts: 3
Here's what I was told. I worked with my WRT54G. "Download the firmware from the Linksys Web site. ( If you have not already done so enable TFTP on your computer. To enable TFTP open Control Panel > Programs and Features > click Turn Windows features On or Off in left side > enable Client TFTP then click in OK. Disable the WIFI on your computer. Set the LAN Port on your computer to use a static IP in the range. Do not use 1, 2 or 20 for xxx. I normally use 100. In order to keep the LAN connection open on the computer it is best to use an Ethernet switch between the node and the computer. Connect a Cat 5 cable between a LAN Port on the node and the Switch and a second Cat 5 cable between the switch and the LAN Port on your computer. In windows explorer navigate to the directory where you placed the firmware file. Right click on the file name and select properties. Highlight the file name and type control-c to copy the file name to the clipboard. Open a command prompt (Start, All Programs, Accessories, Command Prompt) on your computer. In the command prompt window, type but do not press enter TFTP –I put With the cursor in the command prompt window right click your mouse to paste the name of the firmware file into the command. (Be sure to get the full path to the file.) Do Not Press Enter yet. Here is the tricky part. Remove the power from your node, wait a few seconds and plug it back in. About ½ second later, hit enter on the computer to run the TFPT command. You are trying to hit about a small window in the boot up sequence that is about ½ second long. If the TFTP command times out, repeat steps 8 -10 waiting just a little bit longer or shorter to hit enter. Once you hit the window with TFTP command, the node will upload the new firmware and reboot. It should come back up with the factory firmware on it." I have done this to both restore the factory firmware and to reflash the mesh firmware for a forgotten password or buggered configuration issue. YMMV Good luck.
IP Logged
Page # 

Powered by ccBoard